
    <!DOCTYPE html>
    <html >
    <head>
        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        
    <title data-react-helmet="true">Shannon Sharpe: Drew Brees Should Probably Retire</title>
    <meta data-react-helmet="true" charset="utf-8"/><meta data-react-helmet="true" name="description" content="Shannon Sharpe on Drew Brees"/><meta data-react-helmet="true" property="fb:pages" content="154425934607982"/><meta data-react-helmet="true" property="og:title" content="Shannon Sharpe: Drew Brees Should Probably Retire"/><meta data-react-helmet="true" property="og:site_name" content="The Big Lead"/><meta data-react-helmet="true" property="og:image" content="https://images2.minutemediacdn.com/image/upload/c_fill,w_720,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg"/><meta data-react-helmet="true" property="og:url" content="https://www.thebiglead.com/posts/shannon-sharpe-drew-brees-retire-01ea0b7v41pr"/><meta data-react-helmet="true" property="og:image:width" content="720"/><meta data-react-helmet="true" property="og:image:height" content="405"/><meta data-react-helmet="true" property="twitter:title" content="Shannon Sharpe: Drew Brees Should Probably Retire"/><meta data-react-helmet="true" property="twitter:description" content="Shannon Sharpe on Drew Brees"/><meta data-react-helmet="true" property="twitter:site" content="343638363"/><meta data-react-helmet="true" property="twitter:image" content="https://images2.minutemediacdn.com/image/upload/c_fill,w_720,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg"/><meta data-react-helmet="true" property="twitter:url" content="https://www.thebiglead.com/posts/shannon-sharpe-drew-brees-retire-01ea0b7v41pr"/><meta data-react-helmet="true" property="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="robots" content="max-snippet:70, max-image-preview:large, max-video-preview:20"/><meta data-react-helmet="true" name="theme-color" content="#020286"/>
    <link data-react-helmet="true" rel="icon" href="https://images2.minutemediacdn.com/image/upload/v1566980324/frontier/favicons/tbl.png" type="image/png"/><link data-react-helmet="true" rel="canonical" href="https://www.thebiglead.com/posts/shannon-sharpe-drew-brees-retire-01ea0b7v41pr"/><link data-react-helmet="true" rel="amphtml" href="https://www.thebiglead.com/posts/shannon-sharpe-drew-brees-retire-01ea0b7v41pr/amp"/><link data-react-helmet="true" rel="preload" href="https://fonts.googleapis.com/css?family=Montserrat:600,700" as="style"/><link data-react-helmet="true" rel="preload" href="https://fonts.googleapis.com/css?family=Roboto+Slab:400" as="style"/>
    <script data-react-helmet="true" type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.thebiglead.com/posts/shannon-sharpe-drew-brees-retire-01ea0b7v41pr"},"headline":"Shannon Sharpe: Drew Brees Should Probably Retire","image":"https://images2.minutemediacdn.com/image/upload/c_fill,w_720,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg","datePublished":"2020-06-04T19:52:01.885Z","dateModified":"2020-06-04T19:52:01.885Z","author":{"@type":"Person","name":"Kyle Koster"},"publisher":{"@type":"Organization","name":"The Big Lead","logo":{"@type":"ImageObject","url":"https://images2.minutemediacdn.com/image/upload/q_auto/frontier/sites/logos/tbl.png"}}}</script><script data-react-helmet="true" type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-TCW5HW')</script><script data-react-helmet="true" async="true" src="https://www.googletagservices.com/tag/js/gpt.js" type="text/javascript"></script><script data-react-helmet="true" type="text/javascript">!function(){var t=window.location.hostname,e=document.createElement("script"),n=document.getElementsByTagName("script")[0],c=(new Date).getTime(),o="https://quantcast.mgr.consensu.org".concat("/choice/","2wFeGW5ExM-u7","/",t,"/choice.js").concat("?timestamp=",c);e.async=!0,e.type="text/javascript",e.src=o,n.parentNode.insertBefore(e,n)}();var cmpStubFunction=function(){var t=arguments;"object"!=typeof window.__cmp.a&&setTimeout(function(){window.__cmp.apply(window.__cmp,t)},500)},checkIfCmpIsReady=function(){window.__cmp===cmpStubFunction?console.warn("CMP not loaded after 6 seconds. Trying again."):clearInterval(cmpInterval)};if(void 0===window.__cmp){window.__cmp=cmpStubFunction;var cmpInterval=setInterval(checkIfCmpIsReady,6e3)}</script><script data-react-helmet="true" type="text/javascript">window.__cmp&&window.__cmp("getConsentData",null,n=>{n.gdprApplies&&(window.mmClientApi=window.mmClientApi||[],window.mmClientApi.push("injectButtonToFooterLinksSection",{text:"Consent Preferences",onClick:"window.__cmp('displayConsentUi')"}))});</script><script data-react-helmet="true" type="text/javascript">window.__cmp&&window.__cmp("getConsentData",null,n=>{n.gdprApplies&&(window.mmClientApi=window.mmClientApi||[],window.mmClientApi.push("injectButtonToMenu",{text:"Consent Preferences",onClick:"window.__cmp('displayConsentUi')"}))});</script><script data-react-helmet="true" type="text/javascript">window.__cmp&&window.__cmp("uspPing",null,function(n,o){!o||"ca"!==n.location&&"CA"!==n.location||(window.__cmp("setUspDftData",1,function(n,o){}),window.mmClientApi.push("injectButtonToFooterLinksSection",{text:"Do Not Sell My Info",onClick:"window.__cmp('displayUspUi')"}))});</script><script data-react-helmet="true" type="text/javascript">!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js")</script><script data-react-helmet="true" type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-524LTF9');</script><script data-react-helmet="true" async="true" src="https://confiant-integrations.global.ssl.fastly.net/gVg8G70ZiP2pnVNIz9TfdRQopWU/gpt/config.js" type="text/javascript"></script><script data-react-helmet="true" async="true" src="https://assets.revcontent.com/master/delivery.js" type="text/javascript"></script><script data-react-helmet="true" async="true" src="https://assets.minutemediacdn.com/campaign-manager-client/campaign-manager-client.bundle.prod.6acecf0b.js" type="text/javascript"></script><script data-react-helmet="true" >window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);

  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };

  return t;
}(document, "script", "twitter-wjs"));</script>
    
  
        <style data-aphrodite>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</style>
        <script>window.__RENDERED_CLASS_NAMES__ = ["__GLOBAL_STYLES___13tmkvh","foldingDown_170nbrz-o_O-header_ykgsfd","headerFirstRow_1iilhyn","headerFirstRowItemsContainer_u5bwf3","subMenuWrapper_tkhkkr","style_1m0uqvu","wrapper_1ol4hcw","tagStyle_hzsng-o_O-span_1v90eab-o_O-firstSpan_1589aw2","tagStyle_hzsng-o_O-span_1v90eab-o_O-secondSpan_gt478t","tagStyle_hzsng-o_O-span_1v90eab-o_O-thirdSpan_19qrafz","enter_ghq5ck","enterActive_gqbnty","exit_xvw198","exitActive_1stmqyd","largeSvg_1nkatpf-o_O-base_yfvmwq","image_1yfus1e","smallSvg_1qx1a6y-o_O-base_yfvmwq","linkBackground_1sjf62b","fixedNav_kx15tq","navHiddenLayer_1ing288","fixedUl_nkctac","li_8cxs15","span_xsrqq9","tagStyle_tj7l5b-o_O-link_8aw06m","tagStyle_hzsng","button_1lt2y0h-o_O-style_qc65uy-o_O-tagStyle_tj7l5b","caret_74giai","wrapper_sp491z","img_88bdz3","foldingDown_bpx88v-o_O-scrollableNav_g243j8","scrollableUl_nom6cj","li_1bco4pr","style_regn69","ad_1sv27e6","wrapper_1xdxxi9","style_13ui9sx","wrapper_e296pg","tagStyle_1ev9y4p-o_O-title_1bu4x9q-o_O-sidesPadding_1kaga1a","tagStyle_7pk572-o_O-metaData_1b5rj2z-o_O-sidesPadding_1kaga1a","author_1b5rj2z","shareButton_h7tuvd","wrapper_1bxqidu","shareIcon_pq6uhs","style_1y0hmfw","base_613vo1","tagStyle_hzsng-o_O-figcaption_18sqefi","base_1emrqjj","tagStyle_1ot3k1y","tagStyle_589dfs","tagStyle_hzsng-o_O-style_z8n6x8","tagStyle_hzsng-o_O-style_16tsvnu","tagStyle_hzsng-o_O-style_citmd9","style_1sv27e6-o_O-style_citmd9","sidebar_umon5d","ad_1sv27e6-o_O-style_yrewzj","style_1kcasr6","footerWrapper_1eb3lhm","footer_19k1c3d","footerContent_1svmjnc","style_18fggjs","section_r3b6mq","gridWrapper_1sv27e6","linksWrapper_13h40fq","tagStyle_7pk572-o_O-title_ort4mi","base_1mjl8bb-o_O-style_hih7iq-o_O-additionalStyle_3hmsj","style_1fzbmqw","storesWrapper_1i1j07q","circle_neb10l","base_1mjl8bb","wrapper_4iunex","tagStyle_hzsng-o_O-style_1f1tpy6","base_1mjl8bb-o_O-style_gjhxj7-o_O-additionalStyle_3hmsj"];</script>
        <script>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</script>
        <script async type="text/javascript" src="https://assets.minutemediacdn.com/js/PostPageWithRecommendationsAdvertisement.bundle.5a21a9f8.js"></script>
    </head>
    <body  style="margin: 0">
        <div id="mm-root"><header class="foldingDown_170nbrz-o_O-header_ykgsfd"><div class="headerFirstRow_1iilhyn"><div class="headerFirstRowItemsContainer_u5bwf3"><div class="style_1m0uqvu"><div class="wrapper_1ol4hcw"><span class="tagStyle_hzsng-o_O-span_1v90eab-o_O-firstSpan_1589aw2"></span><span class="tagStyle_hzsng-o_O-span_1v90eab-o_O-secondSpan_gt478t"></span><span class="tagStyle_hzsng-o_O-span_1v90eab-o_O-thirdSpan_19qrafz"></span></div></div><a class="largeSvg_1nkatpf-o_O-base_yfvmwq" href="https://www.thebiglead.com/"><img class="image_1yfus1e" alt="The Big Lead" src="data:image/svg+xml,%3C%3Fxml%20version%3D%221.0%22%20encoding%3D%22UTF-8%22%3F%3E%20%3Csvg%20viewBox%3D%220%200%20526.59%2082.52%22%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%3E%20%3Cdefs%3E%20%3Cstyle%3E.cls-1%7Bfill%3A%23020286%3B%7D.cls-2%7Bfill%3A%231cb1e5%3B%7D%3C%2Fstyle%3E%20%3C%2Fdefs%3E%20%3Ctitle%3ETBL_Logo_Primary%3C%2Ftitle%3E%20%3Cg%20data-name%3D%22Layer%202%22%3E%20%3Cg%20data-name%3D%22Layer%201%22%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%2210.8%2056.17%209.66%2064.24%2032.01%2064.24%2030.86%2072.46%208.51%2072.46%207.38%2080.53%200%2080.53%203.43%2056.17%22%2F%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%227.51%2027.08%2037.23%2027.08%2036.07%2035.34%2024.66%2035.34%2023.41%2044.26%2034.82%2044.26%2033.66%2052.52%203.94%2052.52%205.1%2044.26%2015.82%2044.26%2017.07%2035.34%206.36%2035.34%22%2F%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%2233.66%201.99%2040.76%201.99%2038.04%2021.36%208.32%2021.36%2010.99%202.35%2018.07%202.35%2016.54%2013.21%2020.91%2013.21%2022.29%203.45%2029%203.45%2027.63%2013.21%2032.08%2013.21%22%2F%3E%20%3Cpath%20class%3D%22cls-2%22%20d%3D%22M96.84%2C39.06c6.91%2C3.51%2C10.56%2C10.54%2C9.36%2C19.11C104.41%2C70.9%2C92.07%2C80.54%2C77.57%2C80.54H41.37L52.41%2C2H87.89c13.93%2C0%2C22.89%2C8.5%2C21.26%2C20.1-1%2C7-5.8%2C13.33-12.31%2C17ZM88.11%2C25.68c.58-4.08-1.83-6.84-6.35-6.84H70.82L68.9%2C32.51H79.84c4.52%2C0%2C7.7-2.76%2C8.27-6.83Zm-3%2C29.91c.59-4.17-2.07-7.11-6.75-7.11H66.65l-2%2C14.29H76.4c4.69%2C0%2C8.16-2.94%2C8.76-7.18%22%2F%3E%20%3Cpolygon%20class%3D%22cls-2%22%20points%3D%22125.44%201.99%20147.37%201.99%20136.33%2080.54%20114.4%2080.54%22%2F%3E%20%3Cpath%20class%3D%22cls-2%22%20d%3D%22M236.62%2C38.56c-3.61%2C25.7-23%2C44-47.56%2C44-24.06%2C0-39.41-17.3-36.05-41.2A47.57%2C47.57%2C0%2C0%2C1%2C200.46%2C0c20.59%2C0%2C35.62%2C12.88%2C36.38%2C31.14H214.17c-1.92-6.62-8.35-10.87-16.36-10.87-11.76%2C0-20.89%2C8.5-22.65%2C21.05S180%2C62.25%2C191.91%2C62.25c8.26%2C0%2C15.9-4%2C19.22-10H191.62l1.92-13.64Z%22%2F%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%22294.29%2060.72%20291.51%2080.53%20241.63%2080.53%20252.67%201.99%20274.59%201.99%20266.34%2060.72%22%2F%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%22355.05%2061.77%20352.41%2080.53%20301.2%2080.53%20312.24%201.99%20362.5%201.99%20359.87%2020.69%20331.15%2020.69%20329.53%2032.26%20355.33%2032.26%20352.83%2050.01%20327.04%2050.01%20325.38%2061.77%22%2F%3E%20%3Cpath%20class%3D%22cls-1%22%20d%3D%22M414.37%2C67.78H386.53l-6.15%2C12.75H357.19L399.09%2C2h21.15l20.49%2C78.54H416.9ZM406.2%2C26.5l-12%2C24.34h17.29Z%22%2F%3E%20%3Cpath%20class%3D%22cls-1%22%20d%3D%22M526.15%2C41.2c-3.22%2C22.92-22.37%2C39.34-46.08%2C39.34H448.28L459.32%2C2h31.79c23.78%2C0%2C38.26%2C16.26%2C35%2C39.21M504%2C41.2c1.64-11.66-5-19.39-16.66-19.39h-9L472.8%2C60.72h9c11.63%2C0%2C20.49-7.94%2C22.12-19.52%22%2F%3E%3C%2Fg%3E%3C%2Fg%3E%3C%2Fsvg%3E"/></a><a class="smallSvg_1qx1a6y-o_O-base_yfvmwq" href="https://www.thebiglead.com/"><img class="image_1yfus1e" alt="The Big Lead" src="data:image/svg+xml,%3C%3Fxml%20version%3D%221.0%22%20encoding%3D%22UTF-8%22%3F%3E%20%3Csvg%20viewBox%3D%220%200%20526.59%2082.52%22%20xmlns%3D%22http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg%22%3E%20%3Cdefs%3E%20%3Cstyle%3E.cls-1%7Bfill%3A%23020286%3B%7D.cls-2%7Bfill%3A%231cb1e5%3B%7D%3C%2Fstyle%3E%20%3C%2Fdefs%3E%20%3Ctitle%3ETBL_Logo_Primary%3C%2Ftitle%3E%20%3Cg%20data-name%3D%22Layer%202%22%3E%20%3Cg%20data-name%3D%22Layer%201%22%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%2210.8%2056.17%209.66%2064.24%2032.01%2064.24%2030.86%2072.46%208.51%2072.46%207.38%2080.53%200%2080.53%203.43%2056.17%22%2F%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%227.51%2027.08%2037.23%2027.08%2036.07%2035.34%2024.66%2035.34%2023.41%2044.26%2034.82%2044.26%2033.66%2052.52%203.94%2052.52%205.1%2044.26%2015.82%2044.26%2017.07%2035.34%206.36%2035.34%22%2F%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%2233.66%201.99%2040.76%201.99%2038.04%2021.36%208.32%2021.36%2010.99%202.35%2018.07%202.35%2016.54%2013.21%2020.91%2013.21%2022.29%203.45%2029%203.45%2027.63%2013.21%2032.08%2013.21%22%2F%3E%20%3Cpath%20class%3D%22cls-2%22%20d%3D%22M96.84%2C39.06c6.91%2C3.51%2C10.56%2C10.54%2C9.36%2C19.11C104.41%2C70.9%2C92.07%2C80.54%2C77.57%2C80.54H41.37L52.41%2C2H87.89c13.93%2C0%2C22.89%2C8.5%2C21.26%2C20.1-1%2C7-5.8%2C13.33-12.31%2C17ZM88.11%2C25.68c.58-4.08-1.83-6.84-6.35-6.84H70.82L68.9%2C32.51H79.84c4.52%2C0%2C7.7-2.76%2C8.27-6.83Zm-3%2C29.91c.59-4.17-2.07-7.11-6.75-7.11H66.65l-2%2C14.29H76.4c4.69%2C0%2C8.16-2.94%2C8.76-7.18%22%2F%3E%20%3Cpolygon%20class%3D%22cls-2%22%20points%3D%22125.44%201.99%20147.37%201.99%20136.33%2080.54%20114.4%2080.54%22%2F%3E%20%3Cpath%20class%3D%22cls-2%22%20d%3D%22M236.62%2C38.56c-3.61%2C25.7-23%2C44-47.56%2C44-24.06%2C0-39.41-17.3-36.05-41.2A47.57%2C47.57%2C0%2C0%2C1%2C200.46%2C0c20.59%2C0%2C35.62%2C12.88%2C36.38%2C31.14H214.17c-1.92-6.62-8.35-10.87-16.36-10.87-11.76%2C0-20.89%2C8.5-22.65%2C21.05S180%2C62.25%2C191.91%2C62.25c8.26%2C0%2C15.9-4%2C19.22-10H191.62l1.92-13.64Z%22%2F%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%22294.29%2060.72%20291.51%2080.53%20241.63%2080.53%20252.67%201.99%20274.59%201.99%20266.34%2060.72%22%2F%3E%20%3Cpolygon%20class%3D%22cls-1%22%20points%3D%22355.05%2061.77%20352.41%2080.53%20301.2%2080.53%20312.24%201.99%20362.5%201.99%20359.87%2020.69%20331.15%2020.69%20329.53%2032.26%20355.33%2032.26%20352.83%2050.01%20327.04%2050.01%20325.38%2061.77%22%2F%3E%20%3Cpath%20class%3D%22cls-1%22%20d%3D%22M414.37%2C67.78H386.53l-6.15%2C12.75H357.19L399.09%2C2h21.15l20.49%2C78.54H416.9ZM406.2%2C26.5l-12%2C24.34h17.29Z%22%2F%3E%20%3Cpath%20class%3D%22cls-1%22%20d%3D%22M526.15%2C41.2c-3.22%2C22.92-22.37%2C39.34-46.08%2C39.34H448.28L459.32%2C2h31.79c23.78%2C0%2C38.26%2C16.26%2C35%2C39.21M504%2C41.2c1.64-11.66-5-19.39-16.66-19.39h-9L472.8%2C60.72h9c11.63%2C0%2C20.49-7.94%2C22.12-19.52%22%2F%3E%3C%2Fg%3E%3C%2Fg%3E%3C%2Fsvg%3E"/></a><div class="linkBackground_1sjf62b"></div><nav class="fixedNav_kx15tq"><div class="navHiddenLayer_1ing288"><ul class="fixedUl_nkctac"><li class="li_8cxs15"><a href="/media-gossip-musings" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">Media</span></a></li><li class="li_8cxs15"><a href="/podcasts" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">Podcasts</span></a></li><li class="li_8cxs15"><a href="/roundup" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">Roundup</span></a></li><li class="li_8cxs15"><a href="/nfl" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">NFL</span></a></li><li class="li_8cxs15"><a href="/nba" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">NBA</span></a></li><li class="li_8cxs15"><a href="/mlb" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">MLB</span></a></li><li class="li_8cxs15"><a href="/mma" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">MMA</span></a></li><li class="li_8cxs15"><a href="/wwe" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">WWE</span></a></li><li class="li_8cxs15"><a href="/golf" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">Golf</span></a></li><li class="li_8cxs15"><a href="/college-football" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">NCAAF</span></a></li><li class="li_8cxs15"><a href="/college-basketball" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">NCAAB</span></a></li></ul></div></nav><button type="button" class="button_1lt2y0h-o_O-style_qc65uy-o_O-tagStyle_tj7l5b">More<svg class="caret_74giai" width="64" height="10px" viewBox="0 0 64 64" version="1.1"><g id="Icon/DropDown" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><polygon id="Path" fill="#1CB1E5" points="0 16 32 48 64 16"></polygon></g></svg></button></div><div class="headerFirstRowItemsContainer_u5bwf3"><div class="wrapper_sp491z"><a href="https://facebook.com/thebiglead" target="_blank"><img class="img_88bdz3" src="https://images2.minutemediacdn.com/image/upload/c_scale,h_32/shape/cover/entertainment/tbl-facebook-icon.png" alt="facebook"/></a><a href="https://twitter.com/thebiglead" target="_blank"><img class="img_88bdz3" src="https://images2.minutemediacdn.com/image/upload/c_scale,h_32/shape/cover/entertainment/tbl-twitter-icon.png" alt="twitter"/></a></div></div><div class="subMenuWrapper_tkhkkr"></div></div><nav class="foldingDown_bpx88v-o_O-scrollableNav_g243j8"><ul class="scrollableUl_nom6cj"><li class="li_1bco4pr"><a href="/media-gossip-musings" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">Media</span></a></li><li class="li_1bco4pr"><a href="/podcasts" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">Podcasts</span></a></li><li class="li_1bco4pr"><a href="/roundup" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">Roundup</span></a></li><li class="li_1bco4pr"><a href="/nfl" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">NFL</span></a></li><li class="li_1bco4pr"><a href="/nba" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">NBA</span></a></li><li class="li_1bco4pr"><a href="/mlb" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">MLB</span></a></li><li class="li_1bco4pr"><a href="/mma" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">MMA</span></a></li><li class="li_1bco4pr"><a href="/wwe" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">WWE</span></a></li><li class="li_1bco4pr"><a href="/golf" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">Golf</span></a></li><li class="li_1bco4pr"><a href="/college-football" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">NCAAF</span></a></li><li class="li_1bco4pr"><a href="/college-basketball" class="span_xsrqq9"><span class="tagStyle_tj7l5b-o_O-link_8aw06m">NCAAB</span></a></li></ul></nav></header><main class="style_regn69"><div id="div-gpt-ad-1552218170642-0" class="ad_1sv27e6"></div><div class="wrapper_1xdxxi9"><article class="style_13ui9sx"><header><h1 class="tagStyle_1ev9y4p-o_O-title_1bu4x9q-o_O-sidesPadding_1kaga1a">Shannon Sharpe: Drew Brees Should Probably Retire</h1><div class="wrapper_e296pg"><h4 class="tagStyle_7pk572-o_O-metaData_1b5rj2z-o_O-sidesPadding_1kaga1a">By <a href="/author/koster" class="author_1b5rj2z">Kyle Koster</a> | Jun 04 2020</h4><div class="wrapper_1bxqidu"><button type="button" class="shareButton_h7tuvd"><svg viewBox="0 0 16 16" version="1.1" xmlns="http://www.w3.org/2000/svg" class="shareIcon_pq6uhs"><g id="Icons-/-Social-/-Share" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><path d="M9.58105,13.3911 L9.58105,9.7861 C9.58105,9.7861 4.17905,9.4641 5.00000001e-05,14.0001 C5.00000001e-05,14.0001 1.13705,5.6716 9.57955,4.6051 L9.57955,1.0001 L16.00005,7.1946 L9.58105,13.3911 Z" id="share-icon" fill="#1CB1E5" fill-rule="nonzero"></path></g></svg></button></div></div><div class="wrapper_e296pg"><figure class="style_1y0hmfw"><div class="base_613vo1"><picture class="base_1emrqjj"><source srcSet="https://images2.minutemediacdn.com/image/upload/c_fill,w_540,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 1x, https://images2.minutemediacdn.com/image/upload/c_fill,w_1080,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 2x, https://images2.minutemediacdn.com/image/upload/c_fill,w_1620,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 3x" media="(max-width: 719px)"/><source srcSet="https://images2.minutemediacdn.com/image/upload/c_fill,w_720,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 1x, https://images2.minutemediacdn.com/image/upload/c_fill,w_1440,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 2x, https://images2.minutemediacdn.com/image/upload/c_fill,w_1440,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 3x" media="(max-width: 1079px)"/><source srcSet="https://images2.minutemediacdn.com/image/upload/c_fill,w_720,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 1x, https://images2.minutemediacdn.com/image/upload/c_fill,w_1440,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 2x, https://images2.minutemediacdn.com/image/upload/c_fill,w_1440,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg 3x" media="(min-width: 1080px)"/><img class="base_1emrqjj" src="https://images2.minutemediacdn.com/image/upload/c_fill,w_720,ar_16:9,f_auto,q_auto,g_auto/shape/cover/sport/SiriusXM-At-Super-Bowl-LIV---Day-1-663ff081245913661e7171db1ba64b91.jpg" alt="Shannon Sharpe" title="Shannon Sharpe"/></picture></div><figcaption class="tagStyle_hzsng-o_O-figcaption_18sqefi">Cindy Ord/Getty Images</figcaption></figure></div></header><p class="tagStyle_hzsng-o_O-style_citmd9" data-id="_sbqf63hd2">The Drew Brees backlash came with surprising force. And though it will subside as those close to him forgive and forget, things are still quite hot today. Shannon Sharpe offered up some kerosene this morning on <em>Undisputed</em>. </p><p class="tagStyle_hzsng-o_O-style_citmd9" data-id="_iwj2twa7m">After making a string of excellent points, with all understandable passion, Sharpe concluded that Brees should &#34;probably just go ahead and retire.&#34;</p><figure data-id="_8c8nkkkka" class="style_1sv27e6-o_O-style_citmd9"><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Drew Brees should probably retire <a href="https://t.co/61nuI7jjys">pic.twitter.com/61nuI7jjys</a></p>— shannon sharpe (@ShannonSharpe) <a href="https://twitter.com/ShannonSharpe/status/1268575968085463041?ref_src=twsrc%5Etfw">June 4, 2020</a></blockquote></figure><p class="tagStyle_hzsng-o_O-style_citmd9" data-id="_c86lut0b4">Sharpe argues that Brees&#39; teammates will never look at him the same way and that he can&#39;t regain the eroded respect. That is on the possibility spectrum, but we&#39;ve seen a shift toward accepting the contrition in the hours since this on-air comment.</p><p class="tagStyle_hzsng-o_O-style_citmd9" data-id="_hx20bmvp7">In the real world, Brees won&#39;t consider hanging his cleats up -- even for a moment. He&#39;ll still be the most popular athlete in New Orleans&#39; history on opening night. If his support has dipped a bit or legacy ruined are questions for the mid- and long-term, not in the months leading up to September. </p></article><div class="sidebar_umon5d"><div id="div-sideBar1" class="ad_1sv27e6"></div><div id="div-sideBar2" class="ad_1sv27e6-o_O-style_yrewzj"></div></div><div class="style_1kcasr6"><div id="rc-widget-3d8993" data-rc-widget="true" data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="142000"></div></div></div><div id="div-gpt-ad-1552218089756-0" class="ad_1sv27e6"></div></main><footer><div class="footerWrapper_1eb3lhm"><div class="footer_19k1c3d"><div class="footerContent_1svmjnc"><div class="section_r3b6mq"><h4 class="tagStyle_7pk572-o_O-title_ort4mi">LINKS</h4><div class="gridWrapper_1sv27e6"><div class="linksWrapper_13h40fq"><a href="https://www.thebiglead.com/about" class="base_1mjl8bb-o_O-style_hih7iq-o_O-additionalStyle_3hmsj"><p class="tagStyle_hzsng">About</p></a><a href="https://www.thebiglead.com/privacy-policy" class="base_1mjl8bb-o_O-style_hih7iq-o_O-additionalStyle_3hmsj"><p class="tagStyle_hzsng">Privacy Policy</p></a><a href="https://www.thebiglead.com/terms-of-use" class="base_1mjl8bb-o_O-style_hih7iq-o_O-additionalStyle_3hmsj"><p class="tagStyle_hzsng">Terms of service</p></a><a href="https://www.thebiglead.com/cookie_policy" class="base_1mjl8bb-o_O-style_hih7iq-o_O-additionalStyle_3hmsj"><p class="tagStyle_hzsng">Cookie Policy</p></a><a href="https://www.minutemedia.com" class="base_1mjl8bb-o_O-style_hih7iq-o_O-additionalStyle_3hmsj"><p class="tagStyle_hzsng">Contact Us</p></a></div></div></div><div class="style_18fggjs"></div><div class="style_1fzbmqw"><div class="section_r3b6mq"><h4 class="tagStyle_7pk572-o_O-title_ort4mi">FOLLOW US</h4><div class="storesWrapper_1i1j07q"><a href="https://facebook.com/thebiglead" target="_blank" rel="noopener" class="base_1mjl8bb"><div class="circle_neb10l"><img alt="facebook" src="https://images2.minutemediacdn.com/image/upload/c_scale,h_32/shape/cover/entertainment/tbl-facebook-icon.png" height="16"/></div></a><a href="https://twitter.com/thebiglead" target="_blank" rel="noopener" class="base_1mjl8bb"><div class="circle_neb10l"><img alt="twitter" src="https://images2.minutemediacdn.com/image/upload/c_scale,h_32/shape/cover/entertainment/tbl-twitter-icon.png" height="16"/></div></a></div></div></div></div></div></div><div class="wrapper_4iunex"><p class="tagStyle_hzsng-o_O-style_1f1tpy6"><a href="https://www.minutemedia.com" target="_blank" rel="noopener" class="base_1mjl8bb-o_O-style_gjhxj7-o_O-additionalStyle_3hmsj">Powered by Minute Media</a> © 2020 All Rights Reserved</p></div></footer></div>
    </body>
    </html>